Namespace changed and collection upload not working

@L3D I’ve created provider namespaces for ansible-archive and chaos-bodensee and set you as the owner for both.

In regards to your previous questions …

In the old galaxy, I tried to migrate all roles to the l3d namespace, but that progress seems to have been completely lost.

There are quite a few roles in the l3d namespace on new galaxy

[jtanner@p1 ~]$ curl -s | jq .count

(galaxydev) [jtanner@p1 ~]$ ansible-galaxy role search --author=l3d | head

Found 42 roles matching your search:

 Name                                  Description
 ----                                  -----------
 l3d.no_sleep                          Disable (or manage) your screen saver and sleep/suspend of your linux system
 l3d.role_install_strichliste_backened Install the backend
 l3d.role_install_workstaton_packages  Install some base and desktop Packages for your Linux Desktop Computer you could need for your daily linux life! [Feel free to sugest changes]
 l3d.role_pulseaudio_archlinux         Install Pulseaudio Packages on Archlinux
 l3d.acmetool                          Install acmetool, an easy-to-use command line tool for automatically acquiring certificates from ACME servers (eg. Let's Encrypt)

Can you clarify why you think those are lost?

To be honest, I am not really sure how to proceed with the roles on ansible galaxy. @tannerjc, is there any roadmap or idea of what will happen to the roles on galaxy-ng?

I’m not sure what you mean with this question. Can you elaborate?

1 Like

thanks a lot, looks like access to the two missing namespaces is now there :kissing_heart:

A post was split to a new topic: Having trouble choosing which namespace to upload my ansible roles to

Hi @tannerjc I got the same issue with my user pelandrun. Namespace ownership lost


Same issue, my namespace was rangeid, now is rangeid0 and I’m not able to upload new artifact.

We discussed this post in triage, and are marking this solved. If your issue is not yet solved, please open a new thread for your issue.

1 Like

@tannerjc I’m having the same issue as others in this post. Username is namespace was brianaddicks, now it’s brianaddicks0.


@brianaddicks should be fixed now.

1 Like

Hello! As requested here by the @galaxy team, we are closing this thread.

If you run into this issue where your namespace changed, please open a new topic.

Title it “Galaxy namespace changed and uploading (publishing) a collection fails with an error”

And make sure to include the original namespace and the new one (usually the same plus a 0 suffix)

Thank you all for your reports and the Galaxy team for solving each request!