Access to collection

We need help with getting access to this collection Galaxy NG
The collection is being actively developed but with the latest 2.2.0 release we did not see this collection updated in Galaxy. Apparently something broke and we discovered that we can’t find people who initially pushed this collection to Galaxy (admins).
So the ask is to add at least two GitHub repo maintainers (I am one of them) to this collection admins role so we can at least push the latest version of this collection manually to Galaxy and troubleshoot further why it’s not being published automatically.
Please kindly advise what we should do to resolve this issue.
Evgeny Yurchenko.

Here is the Zuul log when you tried to publish 2.2.0 on October 6th:

The relevant part is:

2023-10-06 18:38:19.525376 | controller | ERROR! Error when publishing collection to release_galaxy ( (HTTP Code: 403, Message: You do not have permission to perform this action. Code: permission_denied)

The cause is that the account that Zuul uses to publish collections lost access to all (or a least most) of its namespaces: Bot used for publishing has lost namespace access That was fixed roughly when you tried to publish your collection, so maybe you were a bit too early.

You should try to delete the tag on GitHub and re-push it. That tells Zuul to try to publish it (again). This usually works (assuming the problem isn’t with the collection itself, which doesn’t look to be the case here).

In any case, you should delete the v2.2.0 tag, since that is definitely broken (Update galaxy.yml (#1103) · ansible-collections/community.zabbix@b93862d · GitHub - the version number is invalid as it starts with v).

1 Like

Thank you @felixfontein !
The issue is resolved (for now). Should we be worried that we don’t have admin access to this collection in Galaxy? Is there any “danger” here given the fact that nobody from developers has admin access to this collection?

@BGmot you cannot have admin access to a single collection on Galaxy, only to a namespace. And the community namespace has a lot of collections in it, all with different maintainers. That’s why the Ansible community team is admin for the namespace on Galaxy, and nobody else :slight_smile:

Ok, thanks for explanation. So in community namespace I cannot possible use ansible-galaxy collection publish though somebody put that option in documentation of our repo - step 3 here

Thanks again for your help.

No, you won’t be able to do that. You can ask someone from the Community team to do it for you, but they usually will only do that in emergencies (you really need to release but Zuul doesn’t work, and things like that). I would probably change the wording in that document a bit to emphasize that This requires a user who has access to the community.zabbix namespace (I would also remove the .zabbix) is not something a regular collection admin can do, but is limited to the Ansible Community team (maybe also some others in the Ansible organization have that possibility, but whether they should be doing it or are willing to do it… :person_shrugging:).


Thanks again. Appreciate your prompt help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.