Namespace changed / upload not working, issue with new

Please replace this text with a description of your issue. You should:

Previously we owned two namespaces ‘mondoolabs’ and ‘mondoo’. We claimed the namespace here Request mondoo namespace for ansible role · Issue #2905 · ansible/galaxy · GitHub and used this to publish our roles. At this point, we lost access to all namespaces with the NG update. In addition mondoo/client/ and mondoohq/client should not exist both.

We tried to re-generate the API token, but it has not worked…

I appreciate any help to get this fixed.

@tannerjc Can you help to resolve the issue? We cannot access the namespaces?

The mondoo namespace is owned by what appears to be your github login …

[jtanner@p1 ~]$ curl -s | jq .
  "count": 1,
  "next": null,
  "previous": null,
  "results": [
      "id": 9445,
      "url": "",
      "summary_fields": {
        "owners": [
            "id": 1773,
            "username": "chris-rock"
            "id": 4623,
            "username": "mondoo-tools"
        "provider_namespaces": [
            "id": 8057,
            "name": "mondoo",
            "pulp_href": "/api/pulp/api/v3/pulp_ansible/namespaces/8057/"
      "created": "2023-09-25T14:48:35.859889Z",
      "modified": "2023-09-25T14:48:35.864380Z",
      "name": "mondoo",
      "avatar_url": "",
      "related": {
        "provider_namespaces": null,
        "content": null,
        "owners": "/api/v1/namespaces/9445/owners/"

Please provide more detail about what is not working for you.

  1. during migration it created mondoohq.client and mondoo/client (before it was just one)
  2. The preview image for mondoo/client/ is wrong, which let our users think it was hijacked. It seems that the reference to the git repo of mondoo/client was fixed since yesterday.
  3. I still cannot push new role update , API token is not working
  4. I cannot see my roles in the dashboard (not sure if this is intentional)

In Galaxy NG are you able to click the 3 dot hamburger menu on the right and choose “edit namespace”?

I’m curious if that allows you to define the correct logo url.

Thank you. I was able to update the url for the namespace in collection.

It seems like the role namespaces are completely different and I cannot edit or update those.

I also seemed to lose control of both my namespaces.

Edit: I do seem to have control of my existing roles, but no UI access for updating them. Is this CLI only now? There is a lot missing from the old UI that was fairly basic functionality. IMHO Galaxy NG should not have shipped without it.