Bot used for publishing has lost namespace access

Hey all-

We use a bot and it seems to have lost access to all of the namepsaces it could publish to.

Can the namespace list for “ansibuddy” be restored to what it was on old galaxy?

Thanks, Brad

5 Likes

Since some planned community collection released are coming up soon (i.e. this weekend / next Monday), it would be really great if this could be fixed soon.

@rochacbruno - do you know who can help with this? This is rather urgent, since Ansible 8.5.0 is coming up next week and several collections that should be part of it need to be released.

I believe I have just fixed the ansibuddy account.

3 Likes

Not sure if this is related, but we are still having some issue to release our collection: Zuul

Thanks @tannerjc

We’ve published cisco.nxos and ansible.scm.

Waiting to mark as solved until we hit a few more namespaces.

-brad

2 Likes

We published the cisco.ios collection, the issue looks resolved.
Thanks @tannerjc and @cidrblock

1 Like

I also just was able to publish community.internal_test_tools via Zuul, it worked fine! Thanks a lot everyone! :tada:

2 Likes

The publishing job should be working again. You can retag the release to trigger the pipeline, or if you prefer I can manually publish hetzner.hcloud 2.1.2.

1 Like

Hey,

if you can trigger the release pipeline for this tag or release it yourself, it would be awesome!

Thanks!

@tannerjc Apologies, looks like we also need the hetzner namespace added to the ansibuddy user when you have a chance. Thank you for working through these!!

1 Like

@jillr I added ansibuddy as an owner of the hetzner namespace. The current owners are …

>>> rbac.get_v3_namespace_owners(hetzner)
[<User: tomsiewert>, <User: apricote>, <User: sebfaerber>, <User: JochenABC>, <User: LKaemmerling>, <User: pabelanger>, <User: ansibuddy>]
2 Likes

https://galaxy.ansible.com/ui/repo/published/hetzner/hcloud/?version=2.1.2 You should be all set now

1 Like

Great! Thanks a lot for the work!

@jillr Maybe this is unrelated to this thread, but it seems another of our releases could not be published to Ansible Galaxy because of some permission issues, could you or someone else take a look please ?

https://ansible.softwarefactory-project.io/zuul/build/b02a2cbabf6d4113a9a69654a0998cf8

I expect you may have run into the same problem another collection did last week, which would have been resolved by Re-encrypt galaxy token for ansibuddy by jillr · Pull Request #531 · ansible/zuul-config · GitHub. I’ve manually uploaded 2.2.0 for you to galaxy.

1 Like