ERROR! Failed to download collection tar from 'default': <urlopen error [Errno 111] Connection refused>

Hi everyone,

I noticed today that I can’t download collection anymore.

Error :

~/projects/awx/awx-ee-generator master !5 ❯ ansible-galaxy collection download community.vmware                                                                 34s 10:15:05
Process download dependency map
Starting collection download process to '/home/ramont/projects/awx/awx-ee-generator/collections'
Downloading to /home/ramont/.ansible/tmp/ansible-local-121946xgcueqaw/tmp7acvfk9v/community-vmware-3.9.0-49u93apx
Downloading collection 'community.vmware:3.9.0' to '/home/ramont/projects/awx/awx-ee-generator/collections'
ERROR! Failed to download collection tar from 'default' due to the following unforeseen error: <urlopen error [Errno 111] Connection refused>. <urlopen error [Errno 111] Connection refused>

Ansible version

ansible [core 2.15.4]
  config file = None
  configured module search path = ['/home/ramont/.ansible/plugins/modules', '/usr/share/ansible/plugins/modules']
  ansible python module location = /home/ramont/.local/lib/python3.10/site-packages/ansible
  ansible collection location = /home/ramont/.ansible/collections:/usr/share/ansible/collections
  executable location = /home/ramont/.local/bin/ansible
  python version = 3.10.12 (main, Jun 11 2023, 05:26:28) [GCC 11.4.0] (/usr/bin/python3)
  jinja version = 3.1.2
  libyaml = True

Does anyone have the same issue ?

Best regards


There could be a firewall in the way or your Ansible.cfg file could be broken. It’s hard to tell just from the 111 error. Adding your config file may be a good idea here.

1 Like

Hi @mophahr,

You were right, I forgot that I have an ADGuard activated at home.
It blocked this request… I just need to disable it when I’m working at home (too lazy to fine tuning configurations :stuck_out_tongue: )

Thanks for your answer !

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.