VCenter upgrade

Please help…

We are getting below error while running “vcenter upgrade playbook”

ERROR! couldn’t resolve module/action ‘vmware_vcenter_upgrade’. This often indicates a misspelling, missing collection, or incorrect module path.

The error appears to be in ‘/home/kkrishnasamy/VCenter_Upgrade/VCenter_Upgrade.yml’: line 10, column 7, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

- name: list vmware vcenter upgrade information
^ here

  • hosts: localhost
    name: VCenter_Upgrade
    gather_facts: false
    vcenter_hostname: “x.x.x.x”
    vcenter_username: “administrator@vsphere.local”
    vcenter_password: “Password123!”
    • name: list vmware vcenter upgrade information
      hostname: ‘{{ vcenter_hostname }}’
      username: ‘{{ vcenter_username }}’
      password: ‘{{ vcenter_password }}’
      state: ‘upgrade’
      version: ‘’
      delegate_to: localhost

What module should this be? It looks like neither community.vmware nor vmware.vmware_rest contain a module vmware_vcenter_upgrade.



I tired with both [community.vmware] and [vmware.vmware_rest] but still the same error. please suggest

Is this the module you are looking for?

1 Like

You are right Chris.

But it is not working. Please suggest.

Try this patch and if that doesn’t work raise an issue here?

1 Like

Hi Chris,

I created issue there.
Please note, im using YML .

Have you installed the module and tried applying the patch I linked to above?

1 Like