[solved] Ansible-galaxy collection install community.general fails with 403

Hello,

I’m trying to install collection by running ansible-galaxy colleciton install X but I get an error 403:

Starting galaxy collection install process
Process install dependency map
Starting collection install process
Downloading https://galaxy.ansible.com/api/v3/plugin/ansible/content/published/collections/artifacts/community-general-9.1.0.tar.gz to /home/USER/.ansible/tmp/ansible-local-29479k8yv4hfv/tmpd33r34x9/community-general-9.1.0-2uqlzk28
ERROR! Failed to download collection tar from 'default' due to the following unforeseen error: HTTP Error 403: Forbidden. HTTP Error 403: Forbidden

I tried setting up the ~/.ansible/galaxy_token file like:

token: MY_TOKEN

and when running ansible-galaxy collection install X -vvv I can see that the file is being used. Though I cannot remember every having to setup a token for collections like “community.general”.

Anyone else having problems with galaxy?

Here is some information:

ansible [core 2.15.3]
  config file = /root/MY_PROJ/ansible.cfg
  configured module search path = ['/root/.ansible/plugins/modules', '/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/local/lib/python3.9/dist-packages/ansible
  ansible collection location = /root/.ansible/collections:/usr/share/ansible/collections
  executable location = /usr/local/bin/ansible
  python version = 3.9.2 (default, Feb 28 2021, 17:03:44) [GCC 10.2.1 20210110] (/usr/bin/python3)
  jinja version = 3.1.2
  libyaml = True
2 Likes

We are also having issues, attempting ansible core to the latest now.

@gx0 @Chris_Sibiski see Jul 8, 2024 Ansible Galaxy service degradation info thread

1 Like

I am experiencing the same issue

see Jul 8, 2024 Ansible Galaxy service degradation info thread

1 Like

This should be fixed - [Update: Fixed] Ansible Galaxy service degradation info thread (Jul 8, 2024) - #6 by jlmitch5

Thanks! It’s working again.