Skipping: no hosts matched with global playbook

Hello All

I’m using a global playbook, I mean a playbook dedicated to all my hosts
But when I’m playing for a specific host, or group, I have many

PLAY [xxx_all] ***********************************************************************************************************************************************************************************************************************************************************
skipping: no hosts matched

A line for each not concerned groups

There is a way to hide this message ? I tried ANSIBLE_DISPLAY_SKIPPED_HOSTS without success


Ansible Configuration Docs

Create an ansible.cfg file in your playbook directory with these contents:

display_skipped_hosts = false

See if that helps you.

Same issue, I guess the problem is that I’m using group, the skipping message is about group

I don’t think there’s a config option for it. I do not know/remember the context, but this was declined here "skipping: no hosts matched" even when output is disabled · Issue #67257 · ansible/ansible · GitHub.