Missing variable in installation process for own galaxy server

Hello all,
Can you please help me.
I tried install my own ansible galaxy server ,
Try to follow official way

First guestion was which linux dist. I have to use ?
I have use ubuntu 22 but I have problem with python-dev which does not exist.
Then I have found out I need to use ubuntu 20
all step 1 to 5 it was success deploy with any problem.
then last step
The following provides an example of how to start playbook execution. It assumes an inventory file called hosts exists in the current directory and contains the target host(s) where Galaxy server is to be installed:
ansible-playbook enduser-install.yml -i hosts --extra-vars “@enduser-install-vars.yml

I have create inventory called hosts
[local] localhost ansible_connection=local

then I run it

TASK [pulp_common : Install the Pulp undeclared package dependencies via apt] **********************************************************************************************************************************
fatal: [localhost]: FAILED! => {"msg": "The task includes an option with an undefined variable. The error was: 'pulp_pkg_name_prefix' is undefined\n\nThe error appears to be in '/home/sundrys1/.ansible/collections/ansible_collections/pulp/pulp_installer/roles/pulp_common/tasks/install_packages.yml': line 96, column 7, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n    - name: \"Install the Pulp undeclared package dependencies via {{ ansible_facts.pkg_mgr }}\"  # noqa name[template]\n      ^ here\nWe could be wrong, but this one looks like it might be an issue with\nmissing quotes. Always quote template expression brackets when they\nstart a value. For instance:\n\n    with_items:\n      - {{ foo }}\n\nShould be written as:\n\n    with_items:\n      - \"{{ foo }}\"\n"}

I have tried second instaling process
ansible-playbook enduser-install.yml -i hosts --extra-vars “@upstream-rpm-install-vars.yml

and I have this errors

TASK [pulp_common : Run pip-compile to check pulpcore/plugin compatibility] ************************************************************************************************************************************
[WARNING]: conditional statements should not include jinja2 templating delimiters such as {{ }} or {% %}. Found: {{ failed_condition | default("compatibility.rc != 0") }}
fatal: [localhost]: FAILED! => {"changed": false, "cmd": ["/usr/local/lib/pulp/bin/pip-compile"], "delta": "0:01:39.219897", "end": "2023-10-19 21:46:54.124927", "failed_when_result": true, "msg": "non-zero return code", "rc": 1, "start": "2023-10-19 21:45:14.905030", "stderr": "  ERROR: Cannot install -r requirements.in (line 1) because these package versions have conflicting dependencies.\nDiscarding click==8.1.7 (from -r requirements.txt (line 2)) to proceed the resolution\n  ERROR: Cannot install -r requirements.in (line 1), -r requirements.in (line 2) and pulpcore~=3.22.0 because these package versions have conflicting dependencies.\nTraceback (most recent call last):\n  File \"/usr/local/lib/pulp/lib/python3.8/site-packages/pip/_internal/resolution/resolvelib/resolver.py\", line 95, in resolve\n    result = self._result = resolver.resolve(\n  File \"/usr/local/lib/pulp/lib/python3.8/site-packages/pip/_vendor/resolvelib/resolvers.py\", line 546, in resolve\n    state = resolution.resolve(requirements, max_rounds=max_rounds)\n  File \"/usr/local/lib/pulp/lib/python3.8/site-packages/pip/_vendor/resolvelib/resolvers.py\", line 439, in resolve\n    raise ResolutionImpossible(self.state.backtrack_causes)\npip._

thank you for your help