Issues creating an account

Continuing the discussion from The new Galaxy is completely broken:

Hi @bviktor - I didn’t want to derail the thread you posted this in, so I’ve started a new one here to address the issues you had signing up. Firstly, obviously, sorry you hit an issue in the first place!

That’s highly unusual, and I’ve checked all our logs regarding your account (as it appears today, at least) and can’t find any issues. If you’ve got copies of any logs from your side, please feel free to PM them to me and I’ll look into it more, we don’t want community members excluded for no reason.

The community’s communication methods are documented here ( Other platforms may get you a response but there are no guarantees - we cannot be everywhere, on every platform, sadly.

I’ll take it on the chin that the above page can be perhaps hard to find, though, so let me ask you instead - where did you look next after you hit issues here? Because whatever that place is, we need to signpost from there.


Thanks for reaching out.

Like I said, I’ve been trying for weeks. I’m certain of it, because it’s documented, I’ve even posted to LinkedIn about it 3 weeks ago. Here it is:

Notice the clear paradox of my credentials apparently being both correct and incorrect at the same time, according to the forums.

Sorry if I’m offensive, but If this is not visible in your logs, then maybe your logging is (also) broken.

Regarding how to contact you, if I’m trying to use the Galaxy site, and I’m having issues, I’m taking a look on the Galaxy site, and not on the documentation for Ansible. I’m not assuming that Ansible and Galaxy are the same things, because they’re most certainly not. In fact, I’ve seen several Ansible core developers being openly hostile towards Galaxy on GitHub, for that matter.

The Galaxy site has links like:

  • privacy statement
  • terms of use
  • policies
  • accessibility

But no such thing as “contact”. There’s a “customer support” link to paying RH customers. I’m not one of them.

There’s also a big banner on the top that points to this forum. And that’s about it. Hence my continuous attempts to register here, which, for reasons beyond my understanding, today, finally, worked.

(Btw. I was so annoyed by this, that this time I used a simple placeholder password, which I’d like to change, but I can’t do that either, because there’s no such option as “change password” under account preferences, only password reset, but after all my previous failures, I’m afraid to use that coz I’m afraid I’ll lock myself out lol. And no, it’s not the simpler password that finally allowed me to register, because I also tried with this very same password before, without success.)

Well I put an elaborate answer here, but “Akismet has temporarily hidden your post”. Alright then. I can’t believe how annoying this whole thing is becoming.

I’ve approved it - I would agree that having to have spam-prevention measures in place is indeed tiresome, but such is today’s internet. It won’t apply to you once you’ve been here a while, it only applies to new accounts (because spammers won’t ever hang around long enough to progress out of those restrictions)

I’m guessing logs for that dialog are likely clientside since they have sensitive data in, but I’ll report it upstream anyway and see what I get back.

That’s fair. @galaxy can we include a link to Communicating with the Ansible community — Ansible Documentation somewhere in the Galaxy docs/links? Just in case others are having issues?

I’ll also see if we can customise the account creation dialog, to make it clearer where to get help - people might be coming from places other than Galaxy too.

That is indeed how Discourse handles it, but I can understand your reluctance. I would obviously hope that you don’t have any issues with it, but if you decide to do it and there is a problem, you’re welcome to contact the community team directly about it, either by Matrix or email


Thanks for your help!

1 Like

Perhaps something like this could work…?

1 Like

Super-helpful, thanks @himdel!