Installation Issues with rpm from EPEL

I’m attempting a fresh install on a Rocky v8 VM this morning, but am getting a dependancy error:

  • nothing provides python3.11dist(ansible-core) >= 2.15.3 needed by ansible-8.3.0-1.el8.noarch from epel.

I’m guessing there’s an error in the rpm .spec file where the dependency is defined, but I was wondering if anyone else is seeing this?


Sounds like you’re using a stale EPEL mirror. The current Rocky 8 AppStream is distributing python3.12dist(ansible-core) == 2.16.3, and the current EPEL mirror is distributing ansible-9.2.0-1.el8.noarch and requires python3.12dist(ansible-core) >= 2.16.3. The older versions do not appear to be available anymore.



Yup. I see it now. Going to have to investigate my EPEL setup. Thank you.