Installation galaxy-ng not working


I’m trying to install galaxy-ng following the guide in the documentation (Installation - Galaxy NG).

When trying to access the UI, I cannot login. I can see that the following API requests lead to 404 errors.

http ://myhost:8080/api/galaxy/_ui/v1/feature-flags/
http ://myhost:8080/api/galaxy/_ui/v1/me/
http ://myhost:8080/api/galaxy/_ui/v1/settings/

The only adaption to the configuration file (pulp_settings.env) was replacement of “localhost” with my own FQDN.

Any help appreciated. Is there an alternative way to install ansible-ng on my own server?

Thank you,

Any setting containing “localhost:8080” will be environment specific. Whenever the system is spun up, the backend expects incoming and redirected requests to go to that address. This example uses “localhost:8080” because we will use docker in the next step to bind the underlying host’s port 8080 to the container’s port 80.

The container uses the s6 init system to spin up postgresql, gunicorn, nginx and various pulp services all in the same container. Once migrations have finished and the log entries settle and end with a “New worker XXXXXX discovered”, the system is ready to use.

I don’t think you can change localhost:8080 and use the given docker deployment as is (you might need to set up a reverse proxy, for .e.g). If you want to do a standalone deployment, you might be better off following the instructions here:

Edit: You might not have a UI at all either, since that’s a separate image.