IBM namespace in Galaxy NG has lost most of its users and owners

Hello, prior as ibm namespace owners, ddimatos and itsBryantP; we could see who had access as well as provide access to some of our IBM teams. Now when we view the namespace access tab I see " There are currently no owners assigned" and when either of us try to select my id ddimatos it does not show up. A few hours ago, itsBryantP was able to add himself but now I don’t see them anymore.

One of the IBM teams with prior access with ID freemanlatrell had tried to upload to galaxy today and found that they did not belong to the ibm namespace, they also noticed they could see multiple namespaces with incremental appended values freemanlatrell0, freemanlatrell1 and had been given access to freemanlatrell1 over their original namespace. They opened an issue for this: `publish` is broken · Issue #3255 · ansible/galaxy · GitHub. I do see others reporting the same issue with incremental namespaces.

Is there a way we could return all the IBM namespace users and owners as they were prior to Galaxy NG or will I need to provide a list of the GH IDs?

Some screen captures to help. Below you can see there are no owners assigned:

How would you like us to proceed for the ibm namespace ownership. For me and Bryant is this topic ok, and what about all the other ibm users, should they append to this topic or do you want us to add them to this topic?

It’s not as bleak as the UI makes it seem. We’re using an rbac system under the covers that we historically only managed with groups. However in galaxy we’re managing namespace ownership directly via users. We have pullrequests in flight to make the access page you screenshot-ed capable of listing and managing users instead of just groups.

The “ibm” namespace currently has 60 owners as can be seen by …

[jtanner@corsair ~]$ curl -s | jq .results[0].summary_fields.owners[].username | sort | wc -l
[jtanner@corsair ~]$ curl -s | jq .results[0].summary_fields.owners[].username | sort | head

I triaged and fixed the account for freemanlatrell earlier tonight, however I don’t see any that freemanlatrell was an owner of the ibm namespace on the old galaxy.

The other two users you referenced are owners though …

[jtanner@corsair ~]$ curl -s | jq .results[0].summary_fields.owners[].username | sort | grep -i -e ddimatos -e itsbryan
1 Like

@tannerjc - you are correct freemanlatrell was not an owner, but I (ddimatos) and itsBryantP were so thank you for that. I don’t need to necessarily see the others in the UI, the curl is perfect for me to reference in case others have issues.

I can start another topic, for this if you like, but i don’t see my personal namespace ddimatos under namespaces, see screen capture. Thank you for the speedy turn around, this is awesome.

@tannerjc How was it decided which users were moved over to the new galaxy or not? In our case the user durera is needed in the new galaxy and the lack of that user is stopping us from updating. This user is present in the old galaxy namespace.

@whitfiea I can see durera in the ibm namespace:

ddimatos:[ ~ ]curl -s | jq .results[0].summary_fields.owners[].username|sort |grep -i durera

Interesting. I’m going to try to regenerate my API token, maybe that will help get things moving again.

Regenerating the API token (Galaxy NG) seems have done the trick, or something else changed since we last tried and were hitting Error when finding available api versions from default ( (HTTP Code: 403, Message: Forbidden)