Galaxy - 500 errors / API Key Not Working

First I was attempting to publish a new version of our collection via ansible-galaxy collection publish command and I got a 403 error. So I went to try to investigate what was going on with my token. Then when attempting to log in I’m now getting server 500 errors.


Note that the login was using GitHub auth.

Same here; my existing API token appears to be invalid (which is fine), but I cannot log in to Galaxy NG to obtain a new one or even just update my published collection. Galaxy prompted me to authorize my GitHub account again and now immediately returns a 500 upon attempting to log in.

Same issue on my end. Tried to revoke my Github auth application grants as well and re-establishing the oauth flow again still results in 500 from galaxy.

Hi there.

I had the same issue

and i have just found a solution.

You will need to open your GitHub Account Settings, go to Applications and open an Authorized OAuth Apps tab, or try to open a link below, then revoke all Ansible Galaxy applications.

As i understand, it happenes because of GitHub stores Legasy-Ansible-Galaxy keys in its Authorized OAuth App


I didn’t have to do anything this morning and now it is working. Guessing that there was in fact some system issues at some point.

Can confirm, and generating a new API token worked as well, thankfully. Quite scary, though.

My API keys are not working either. I’m trying to upload a role in a github action. I only see API keys under the collections tab. Does that mean I can no longer upload just a role?

(also I would open a new topic - but I can’t seem to do so…)

1 Like

There’s no restrictions on creating a new topic, @johrstrom, you should be able to. Are you getting an error of some kind?

EDIT: moved here: Can't seem to start a new topic via button (works by URL)

2 posts were split to a new topic: Can;t seem to start a new topic via button (works by URL)

I revoked the Authorize OAuth APPs and continue to see a Server Error (500)

This morning it works.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.