Awx in offline enviorment - issue with EE image


Hi ,
i Am using AWX version 23.5.1 with docker compose. I preformed the installation in online machine and then moved it as OVF to my server(offline).
Of course , I tested everything in the online machine to verify that I am not running into any problems.
After that I moved it , I tried to run jobs but I got this error

Error: initializing source docker:// pinging container registry dial tcp: lookup on read udp> i/o timeout

So I tried to pull the image online and inserting it to my offline machine with docker load …
and I ran to the same issue.

I saw a lot of tutorials in creating custom execution environment and etc. but I currently only need to make it work ,

Thanks in advance

Hello @Ron welcome to the community!

There is an option on AWX to pull an EE image only when it’s missing. If I recall correctly, the default is to pull always, even when the image is present. Can you double check that?

Hope it helps

Hi Ron,
Were you able to find a fix for this issue? we came across the same behavior and can’t run any jobs.