Ansible-galaxy search not working?

My namespace is at Galaxy NG but when searching for --author konstruktoid I find 1536 roles…
Token is set in ansible.cfg.

$ ansible-galaxy role search --help
usage: ansible-galaxy role search [-h] [-s API_SERVER] [--token API_KEY] [-c] [--timeout TIMEOUT] [-v] [--platforms PLATFORMS] [--galaxy-tags GALAXY_TAGS] [--author AUTHOR] [searchterm ...]
$ ansible-galaxy role search --author konstruktoid docker

Found 1536 roles matching your search. Showing first 1000.

I think I see the issue. Passing the --author option causes a search url like so …

Calling Galaxy at

We did add support for the “autocomplete” parameter, but missed the “username_autocomplete” parameter, which causes it to be ignored during filtering.

I’ve opened a bug for it Loading...