The default execution environment cannot mount the local nfs storage volume

I deployed awx-operator in the kubernetes cluster. I want to mount the local nfs storage volume to the default awx-ee execution environment. I configured it in the settings by viewing the official documentation. I tried to re-image but failed. Can anyone ask? Can you help me solve this problem?

Are there any mature examples to share and answer my questions?

Hi, is my understanding correct that some of your tasks in your playbook require NFS storage?

You can customize pod specification for your execution environment by creating Container Group with customized pod spec: 7. Container and Instance Groups — Ansible AWX community documentation

As with mounting NFS storage on a standard pod on kubernetes cluster, simply create a PV/PVC and define volumes and volumeMounts in the pod spec.


Thank you bro, your suggestion solved my problem, I am not very familiar with awx, thank you。

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.