Slow execution of Ansible template in AWX 23.0

I have noticed that in AWX 23.0, my Ansible template sometimes is executed very slowly, and it seems that this is related to the fact that sometimes when a template is executed, AWX itself first has to sync the inventory of this template, after the sync of inventory is done, then the template itself will be executed.

This has added more time in the execution time. My inventory is not changed frequently, thus I prefer not to sync the inventory every time when the template is executed.

I assume there should be a setting, but I could not find in GUI

Anyone has an idea ?

Many thanks !

@mapleos1123 hello! We do have a cache_timeout that can be set in the inventory. We would recommend doing some research around that.

1 Like