Semaphore fails ansible-playbook succeeds

When I run my playbook ansible connects properly to the remote machine and executes all commands just fine.

When I run the same playbook from the semaphore UI I get → ssh connection error.

It’s obviously an ssh error but I dont understand why since it works without semaphore.

Could someone pls point me in the right direction?


The reason for the error was that the remote machine had the wrong ssh key in the authorized_hosts file. When I log in to the Master machine I use ssh agent forwarding so the first time I connected to the slave-machine the wrong key was automatically passed to the authorized_hosts.

When you run the playbook and it succeeds, are you running it from the same server that is hosting the Semaphore installation?

I don’t believe Semaphore is supported here, I think it is a whole separate entity.

You could try searching / posting to their issues tab in GitHub (Issues · ansible-semaphore/semaphore · GitHub), but I don’t think anyone actively supports it anymore - at least that’s why I abandoned using it.

Good luck!

There seems to be some recent activity, and from several people. It may be less moribund than you think. (I’ve never used it. In fact I don’t recall hearing about it before now. Looks like a “personal AWX” from a very brief glance.)

Oh, interesting. It is basically a simpler AWX, with a far better GUI (in my opinion).

For the OP - in matrix/irc a while back, people recommended Rundeck as an alternative to Semaphore. I haven’t tried it.

I ended up using some simple buttons on an existing in-house web app to do what I needed.

Yes, but lt’s resolved now see my added info above and thanks for answering.

1 Like

It is working fine and the gui is very nice in general. A little bit unclear when it comes to auth keys and permisson elevation etc but the best that l have found so far.