Raspberry Pi + HQ camera as a webcam Github project using ansible


First of all, I don’t know anything about ansible, I just had to use it two years ago to build this project : GitHub - geerlingguy/pi-webcam: Automation to configure a Raspberry Pi as a USB OTG webcam

Two years ago, it was working fine (I have a RPi 4B), I think I was using RPiOS Bullseye or Buster, but it was in 2022 so I think it was Bullseye. I wanted to use this project to have a HQ webcam for astronomy.

Two years after, now, I plugged the RPi again on my new OS (Linux Mint) but dmesg -w returned only errors, couldn’t identified the plugged device as a webcam… So I thought : “It has to be my laptop OS, let’s go back to Ubuntu 20.04” but it failed again.

So I’ve decided to pull out the SD card from the RPi and restart things over. I’ve used the latest RPiOS “Bookworm” (Lite version) but after a successful installation, dmesg -w couldn’t recognize anything still when plugged to my laptop. I plugged my RPi on a monitor and I understood what the problem was : the script wasn’t running at boot, no idea why.

So I formatted the SD card again to install Bullseye : same, the script wasn’t running at boot.

Then, I discovered this blog article : How use your Raspberry Pi as a webcam | by Eduardo Padron | Medium from August 2023.

The author said that only Raspbian Buster could make the project work at this time. So I put Buster on my SD card but my RPi 4B couldn’t boot, I fixed it by replacing the start4.elf and fixup4.dat files by the most recent ones and then I could make it boot.

I then followed again the instructions but when I tried to install ansible, the terminal said that it was impossible to install ansible 2.11 or newer, I found it confusing because, as you can see in the blog article screenshots, the author can install ansible-core-2.11.12 perfectly without errors.

It’s been a month that I spend nights and days to figure this out, trying other projects that are also deprecated (3 or 4 years old without any updates).

I was able to turn my RPi 4B + HQ camera as a webcam again with this tutorial, but it was made for the Pi camera module 3 (can’t put two links as a new user, but you can find it by typing raspberry pi as webcam tutorial on Google, it’s called “Plug-and-play Raspberry Pi USB webcam”. It worked, but only at 720p, while the HQ camera can go up to 4K !

Could you tell what happened since August 2023 so that ansible-core cannot be installed anymore on Buster ? Is there any way to fix this problem ? I came to you because the Github project is practically abandoned, the author didn’t update it since 4 years and doesn’t reply to issues on his Github.

Thank you very much.

The python 3 version on Buster is 3.7.3 so ansible-core 2.11.x is the latest you can install using pip3.

Or enable backports and install the latest Debian version, 2.9.16.

1 Like