Latest version of Ansible not supported by popular collections

Are there new commands for Ansible 2.15.3? It seems that the following collections are no longer supported:

[WARNING]: Collection openvswitch.openvswitch does not support Ansible version 2.15.3
[WARNING]: Collection ibm.qradar does not support Ansible version 2.15.3
[WARNING]: Collection cisco.iosxr does not support Ansible version 2.15.3
[WARNING]: Collection does not support Ansible version 2.15.3
[WARNING]: Collection ansible.netcommon does not support Ansible version 2.15.3
[WARNING]: Collection cisco.nxos does not support Ansible version 2.15.3
[WARNING]: Collection vyos.vyos does not support Ansible version 2.15.3
[WARNING]: Collection ansible.posix does not support Ansible version 2.15.3
[WARNING]: Collection frr.frr does not support Ansible version 2.15.3
[WARNING]: Collection junipernetworks.junos does not support Ansible version 2.15.3
[WARNING]: Collection cisco.asa does not support Ansible version 2.15.3

Which are making my playbooks unusable. I am not seeing in the documentation that there are different sets of commands for the latest version. What am I missing?


I have a few questions, top of my head:

  • For starter, on which commands do you get these WARN from ?
  • What version of these collections are installed on your machine (ansible-galaxy collection list) ?
  • Also, do you use any other tool than pure ansible-galaxy that might manage collections as well, and perhaps depends on older versions; I’m thinking AWX would do that, though I don’t use it so I’m not sure ?
  • How did you upgrade Ansible packages in the first place ?
1 Like

Hi Pierre,

I mostly get this warning when I am running a playbook that includes cisco.nxos modules and commands.
The collection that includes commands for Cisco Nexus switches is ansible.netcommon. I imagine once we start writing playbooks for our juniper machines we will encounter the same issue.

When I installed ansible-core, it installed version 2.15.3.

Thanks for the precisions Wendy. It seems to me that you are using older collections, that were not updated with ansible packages upgrade. Could you tell us what version of these collections are installed ? And if you use other tools on top of Ansible.

Also, what happens if you try to install one of these manually, for example: ansible-galaxy collection install ansible.netcommon, maybe with --force, see if it upgrades ?

1 Like

Hi Pierre,

When I try to re-install the collection I get the long list of warnings that I provided previously. Adding the --force parameter results in the same list of warnings.

How do I check for the version of the collection? Where can I find the updated collections?

I am running Ansible on Ubuntu 22.04.1 LTS.

Can you try:

ansible-galaxy collection list

As @ptn suggested above


ansible.netcommon is showing as version 1.5.0
cisco.nxos is showing as version 1.4.0
junipernetworks.junos is showing as version 1.3.0

Those are old versions! The latest versions for these collections:


how do I get the updated versions?

See installing collections?


Appart for the warns, what is the output ? --force should reinstall collection from the latest version, except maybe if there is a dependence issue, though I’m not sure how ansible-galaxy works on that level.

You could always install collections somewhere else with --collections-path flag (or -p), then use this path in your config (export ANSIBLE_COLLECTIONS_PATHS=… would be one way to do it), though that wouldn’t tell us why you still have old versions lying around.
Perhaps you already have those collections up to date somewhere but use another path in your config already ?

Could you output ansible --version as well ?


output of ansible --version:

ansible [core 2.15.3]
config file = None
configured module search path = [‘/home/leon0425/.ansible/plugins/modules’, ‘/usr/share/ansible/plugins/modules’]
ansible python module location = /home/leon0425/.local/lib/python3.10/site-packages/ansible
ansible collection location = /home/leon0425/.ansible/collections:/usr/share/ansible/collections
executable location = /home/leon0425/.local/bin/ansible
python version = 3.10.12 (main, Jun 11 2023, 05:26:28) [GCC 11.4.0] (/usr/bin/python3)
jinja version = 3.0.3
libyaml = True

1 Like

ansible collection location = /home/leon0425/.ansible/collections:/usr/share/ansible/collections

I was interested to see if you had a specific path in there, but those are the default. No need to delve deeper IMO.

Still waiting for ansible-galaxy collection install ansible.netcommon [--force] (ansible.netcommon as an example), which might give us some useful information. Check version afterwards.
Else, just try to upgrade all of them: ansible-galaxy collection install --upgrade and paste the output here. At this point, I fail to see why it wouldn’t work.


After working through an internal proxy issue that was causing the: ansible-galaxy collection install --upgrade to fail. I was able to get the collections updated.

Thank you for all of your help. :smile:


Please note that this is the ansible-core version. Ansible does not have a 2.15.x version at all, its current versions are in the 8.x.y range.


Hi @wendyodsm , welcome to the community forum!

Thank you for letting us know you solved the issue. From the thread I think this post by @ptn could be considered the solution:

We would appreciate if you tick the check-box at the bottom of that post to mark the thread as solved, this way we recognize the helpers and also keep the forum tidy!

And a ++ to @chris for the help there :wink:


It’s been another week, so I’ve accepted @ptn’s post as the solution. Please do reply if that’s incorrect :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.