Ebbba.bigbluebutton - Can't import in galaxy

It has been some time since my last post:

Which was an issue fixed by this merge => support legacy role import overrides for namespace and name. by jctanner · Pull Request #2011 · ansible/galaxy_ng · GitHub


Now I can still not update / import our role:
https://galaxy.ansible.com/ui/standalone/roles/ebbba/bigbluebutton/import_log/

This makes it look like the role has been stale since 10 months and there are no updates happening, which is in fact wrong.
https://github.com/ebbba-org/ansible-role-bigbluebutton/releases

I am at my wits end, can someone enlighten me?

How is the role being imported into galaxy? Can you show the workflow file or the full command you are using?

No command is used :grimacing: I use the site to start a new import of a tag or branch, but it does nothing.

The UI doesn’t bring you to a task page or an import log after clicking submit?

I just attempted an import of the role on the stage system. After filling out the form and clicking submit, the modal form closed and I was back to looking at Ansible Galaxy … however at the top right of the page there was an alert box showing me a link to the import task.

https://galaxy-stage.ansible.com/ui/task/01906eb6-8f16-7871-8f41-f40c878e6c19/

unknown field in galaxy_info: LegacyGalaxyInfo.__init__() got an unexpected keyword argument 'standalone'

That error comes from this line in the meta/main.yml …

I haven’t found a good document that explains the purpose of the field or if we ever truly supported it. However, at this time the backend does not allow it and you’ll need to remove it from the file.

2 Likes

Sorry for the late reply.
Thanks for looking into it.
I will remove it and test again.

That worked, thank you very much!

https://galaxy.ansible.com/ui/standalone/roles/ebbba/bigbluebutton/versions/