Bad owner or permissions on /etc/ssh/ssh_config.d/50-redhat.conf

Hi Team,

I often end with the following error in AWX job execution {
“unreachable”: true,
“msg”: “Failed to connect to the host via ssh: Bad owner or permissions on /etc/ssh/ssh_config.d/50-redhat.conf”,
“changed”: false

kindly assist on this please


First off, I moved your post in Get Help section, which seems more suited to what you’re looking for (@gwmngilfen Hope that’s ok).

Error message seems pretty clear to me; have you checked ownership and ACL on “/etc/ssh/ssh_config.d/50-redhat.conf” file ? File should be owned by the user running commands through ssh, and permissions should be 0600 or 0644 IIRC.

1 Like

Hello @nx2804,
Congratulations on your first post, and welcome!

We wanted to gather a bit more information from you in order to better assist you. What EE image are you using in this situation? This will better help us understand what may be occurring here.

Thank you for your time!

I am not the OP, but I am running into this error when using ansible-navigator.

My playbooks work fine when run from AAP, and when run using ansible-playbook, I just get the error when running them with ansible-navigator.

Perms on /etc/ssh/ssh_config.d/50-redhat.conf:
-rw-r–r–. 1 root root 581 Jul 20 2023 /etc/ssh/ssh_config.d/50-redhat.conf

For the Execution Environment, I have tried using both a custom one and a RH supplied one, but the error happens with both.
They are:

I should also point out that this error is new. Navigator worked fine a few days ago. I cannot find anyone who will admit to changing anything in the environment, but that is a possibility, I just don’t know where to look or what changes could affect this.

Thank you, any help would be greatly appreciated!

hey @akvalentine I would suggest maybe creating a navigator issue if whatever solution that might come from this post doesn’t help you. While the errors are the same, how each tool might handle or throw the error might be different.

This would help the folks who work on navigator assist you more easily.

1 Like

Sorry for the late reply , Iam using image