AWX job failure due to psutil python module


We have a job template called update_telegraf to deploy telegraf configurations.
the issue is that as soon as we launch the job template it fails very quickly stating:

It is failing when psutil is trying to call one function.And this is happening for only 1 server.Rest all places it is working fine.

System Details:
Ansible_Deployment_type: docker container
OS: Rhel7.9
AWX version: 17.1.0
Ansible: ansible 2.9.18
config file = /etc/ansible/ansible.cfg
configured module search path = [‘/var/lib/awx/.ansible/plugins/modules’, ‘/usr/share/ansible/plugins/modules’]
ansible python module location = /usr/lib/python3.6/site-packages/ansible
executable location = /usr/bin/ansible
python version = 3.6.8 (default, Aug 24 2020, 17:57:11) [GCC 8.3.1 20191121 (Red Hat 8.3.1-5)]

Python: 3.6.8
psutil_module_version: 5.9.5

Even if we try to import it manually it fails and produces this error AttributeError: module ‘psutil._psutil_posix’ has no attribute ‘getpagesize’

for investigation purpose I just hardcoded the page size to 4096 and then relaunched the job so then I got this error

ERROR! Unexpected Exception, this is probably a bug: version conflict: '/var/lib/awx/venv/ansible/lib/python3.6/site-packages/psutil/' C extension module was built for another version of psutil (5.7.0 instead of 5.9.5); you may try to 'pip uninstall psutil', manually remove /var/lib/awx/venv/ansible/lib/python3.6/site-packages/psutil/ or clean the virtual env somehow, then reinstall

Since there is no internet connectivity so I took the psutil module zip file manually and then tried to run reinstallation but it did’nt worked because when it tries to install the module it runs setup and wheel from internet and it fails.

Recently we had OS patching,so can it be the reason ?

This issue has been fixed.

1 Like