AWX cannot download collections / roles from the new galaxy

Hey everyone!

Since today our AWX instances (23.1.0) fail to download collections and roles from the new ansible galaxy. A 403 is returned all the time. I suspected the token and tried to create a new one, but the page to manage tokens seems to be gone (Galaxy NG).

How can i fix this?

ERROR! Error when finding available api versions from server0 ( (HTTP Code: 403, Message: Forbidden)

Did you try the API token from Galaxy NG ?
Maybe that will work. (But I don’t know, not using AWX so far)

Did you checkt what version of ansible the AWX is using. For background info have a lokk at this post: Unable to install collection from new Galaxy - #4 by jskacel

Ah yes, totally overlooked that page. Should be updated in the docs as well i guess: ansible-galaxy — Ansible Documentation

Now i just get a different error:

ERROR! Unexpected Exception, this is probably a bug: '/api/v3/plugin/ansible/content/published/collections/index/community/general/versions/'

Not sure which ansible version our AWX is using, but we are only one version behind the latest release. And it seems i am not the only one that has issues:

1 Like

5 posts were split to a new topic: Errors with ansible-galaxy and new token

It worked for me after i updated to the latest version of the awx-ee container here:

On my macOS it worked with v2.15.4