ansible playbook works manually but fails from the server

I’m running an Ansible playbook to deploy a small website, but the playbook behaves differently when I run it from the server. same task works when I test it manually, but ansible returns an error when it tries to access the website files. I’ve checked the pth and permissions, but I’m not sure what I’m missing. could the issue be related to the user or permissions Ansible is usig?

Welcome @iuslabrownn Could you please add a link to the GitHub repository for your website? Or copy/paste the task from your playbook that you’re trying to debug?

Thank you!