Cannot install some roles anymore, tries to import from GitHub user `None`

When trying to run ansible-galaxy role install ansistrano.deploy, I get:

Starting galaxy role install process
- downloading role 'deploy', owned by ansistrano
- downloading role from
 [ERROR]: failed to download the file: HTTP Error 404: Not Found
[WARNING]: - ansistrano.deploy was NOT installed successfully.
ERROR! - you can use --ignore-errors to skip failed roles and finish processing the list.

The problem here is that None is used instead of ansistrano. I guess this comes from the metadata galaxy_ng is delivering.

I don’t know whether the role authors did anything to that role (Galaxy claims the last release is from a year ago), but this is part of the community.general tests (for the ansible_galaxy_install module) and it worked until yesterday, and started failing completely today.


This also happens for other roles, such as felixfontein.acme_certificate. I guess this might be a general Galaxy roles problem. (Since that’s my role I know for sure that there hasn’t been a release for some time now. The last release was before the migration to the new Galaxy.)

Can confirm; another role I regularly use (nickjj.docker) is no longer installable either and cannot be found using the Galaxy search. Also, it is very unlikely to have been taken down by its author.

I think this should be fixed now, can all of you please try installing again?


For the two roles I tried it’s now working. I’ve also been able to re-enabled the tests for community.general.ansible_galaxy_install succesfully (Revert "Disable ansible_galaxy_install tests until Galaxy is fixed (#7440)" by felixfontein · Pull Request #7446 · ansible-collections/community.general · GitHub) - or at least the tests that ran so far, AZP seems to be too busy right now.

Works again; thanks for the quick fix.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.