# Unsupported Parameter ? module: security (vmware\_vswitch)

**URL:** <https://forum.ansible.com/t/unsupported-parameter-module-security-vmware-vswitch/3729>\
**Category:** Get Help\
**Tags:** vmware, ubuntu, collections\
**Created:** [February 7, 2024, 9:37am UTC](https://forum.ansible.com/t/unsupported-parameter-module-security-vmware-vswitch/3729 "2024-02-07T09:37:06Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Dragao](https://avatars.discourse-cdn.com/v4/letter/d/ecb155/32.png) [@Dragao](https://forum.ansible.com/u/Dragao)\
**Post date:** [February 7, 2024, 9:37am UTC](https://forum.ansible.com/t/unsupported-parameter-module-security-vmware-vswitch/3729/1 "2024-02-07T09:37:06Z")

</div>

Hi All,

Using examples from the documentation I can create a vswitch on our esxi host (v7)  
But when I try to add settings like Teaming or security the playbook fails stating the parameter is unsuported.

ansible [core 2.12.10]  
python version = 3.8.10 (default, Nov 22 2023, 10:22:35) [GCC 9.4.0]  
jinja version = 2.10.1  
libyaml = True  
Running on Ubuntu 20.04.06

Relevant code from playbook:

```auto
  - name: Add vSwitch
    community.vmware.vmware_vswitch:
     validate_certs: false
     esxi_hostname: "{{ esxi_hostname }}"
     hostname: "{{ vcenter_ip }}"
     username: "{{ vcenter_user }}"
     password: "{{ vcenter_pass }}"
     switch: vmware_vsitch_0004
     nic_name: vmnic3
     mtu: 9000
     security:
       promiscuous_mode: true
    delegate_to: localhost

```

Any suggestions?

---

<div class="post-metadata">

**Author:** ![kurokobo](https://sea1.discourse-cdn.com/ansible/user_avatar/forum.ansible.com/kurokobo/32/182_2.png) [@kurokobo](https://forum.ansible.com/u/kurokobo)\
**Post date:** [February 7, 2024, 11:46am UTC](https://forum.ansible.com/t/unsupported-parameter-module-security-vmware-vswitch/3729/2 "2024-02-07T11:46:36Z")

</div>

Hi, could you please provide actual error messages and the version of the collection `community.vmware` that installed on your environment?

---

<div class="post-metadata">

**Author:** ![Dragao](https://avatars.discourse-cdn.com/v4/letter/d/ecb155/32.png) [@Dragao](https://forum.ansible.com/u/Dragao)\
**Post date:** [February 7, 2024, 12:10pm UTC](https://forum.ansible.com/t/unsupported-parameter-module-security-vmware-vswitch/3729/3 "2024-02-07T12:10:33Z")

</div>

this is the error:

TASK [Add vSwitch] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*  
fatal: [xxxxxxx → localhost]: FAILED! =\> {“changed”: false, “msg”: “Unsupported parameters for (community.vmware.vmware\_vswitch) module: security. Supported parameters include: hostname, esxi\_hostname (host), mtu, password (pass, pwd), switch (switch\_name), username (admin, user), state, number\_of\_ports, proxy\_port, nics (nic\_name), validate\_certs, proxy\_host, port.”}

Version of community is 4.1.0

---

<div class="post-metadata">

**Author:** ![kurokobo](https://sea1.discourse-cdn.com/ansible/user_avatar/forum.ansible.com/kurokobo/32/182_2.png) [@kurokobo](https://forum.ansible.com/u/kurokobo)\
**Post date:** [February 7, 2024, 12:30pm UTC](https://forum.ansible.com/t/unsupported-parameter-module-security-vmware-vswitch/3729/4 "2024-02-07T12:30:26Z")

</div>

Thanks,

> Supported parameters include: hostname, esxi\_hostname (host), mtu, password (pass, pwd), switch (switch\_name), username (admin, user), state, number\_of\_ports, proxy\_port, nics (nic\_name), validate\_certs, proxy\_host, port.”}

This params seems to be [the params for 2.3.0 or earlier](https://galaxy.ansible.com/ui/repo/published/community/vmware/content/module/vmware_vswitch/?version=2.3.0).

> Version of community is 4.1.0

Are you seeing both the old `community.vmware` and the new `community.vmware` in the command results of `ansible-galaxy collection list | grep community.vmware`?

---

<div class="post-metadata">

**Author:** ![Dragao](https://avatars.discourse-cdn.com/v4/letter/d/ecb155/32.png) [@Dragao](https://forum.ansible.com/u/Dragao)\
**Post date:** [February 7, 2024, 2:41pm UTC](https://forum.ansible.com/t/unsupported-parameter-module-security-vmware-vswitch/3729/5 "2024-02-07T14:41:21Z")

</div>

There seems to be a problem with my installation i guess.

ansible-galaxy collection: error: argument COLLECTION\_ACTION: invalid choice: ‘list’ (choose from ‘init’, ‘build’, ‘publish’, ‘install’)

---

<div class="post-metadata">

**Author:** ![kurokobo](https://sea1.discourse-cdn.com/ansible/user_avatar/forum.ansible.com/kurokobo/32/182_2.png) [@kurokobo](https://forum.ansible.com/u/kurokobo)\
**Post date:** [February 7, 2024, 3:11pm UTC](https://forum.ansible.com/t/unsupported-parameter-module-security-vmware-vswitch/3729/6 "2024-02-07T15:11:06Z")

</div>

Thanks, so if you truly have core 2.12.10 installed, you should also be able to use `ansible-galaxy collection list`, so it sounds like you have something old left on your system.

Before correcting collection problems, check the version of Ansible you are running and try to fix the installation.

```bash
$ ansible --version
$ ansible-galaxy --version
$ ansible-config dump --only-changed -t all # remove "-t all" if you got error

```

---

<div class="post-metadata">

**Author:** ![Dragao](https://avatars.discourse-cdn.com/v4/letter/d/ecb155/32.png) [@Dragao](https://forum.ansible.com/u/Dragao)\
**Post date:** [February 7, 2024, 3:27pm UTC](https://forum.ansible.com/t/unsupported-parameter-module-security-vmware-vswitch/3729/7 "2024-02-07T15:27:53Z")

</div>

Well, did an upgrade to ansible version 2.9.6 (maybe should not have done that)  
Ansible-galaxy is also v2.9.6

these are the changes:  
ansible-config dump --only-changed

DEFAULT\_BECOME\_ASK\_PASS(/etc/ansible/ansible.cfg) =

DEFAULT\_HOST\_LIST(/etc/ansible/ansible.cfg) =

DEFAULT\_REMOTE\_USER(/etc/ansible/ansible.cfg) =

Am thinking about starting all over with Ansible as we are not yet in production. Current Ubuntu is 20.04 so we could upgrade that as well …

---

<div class="post-metadata">

**Author:** ![kurokobo](https://sea1.discourse-cdn.com/ansible/user_avatar/forum.ansible.com/kurokobo/32/182_2.png) [@kurokobo](https://forum.ansible.com/u/kurokobo)\
**Post date:** [February 7, 2024, 3:53pm UTC](https://forum.ansible.com/t/unsupported-parameter-module-security-vmware-vswitch/3729/8 "2024-02-07T15:53:47Z")

</div>

Ubuntu 20.04 is still maintained since it is LTS, but Ansible 2.9.6 is quite old, it is already in EOL.  
If it is possible, I recommend you to the latest stable releases; Python 3.12 and Ansible 9.x (includes ansible-core 2.16).

Refer to: [Releases and maintenance — Ansible Documentation](https://docs.ansible.com/ansible/latest/reference_appendices/release_and_maintenance.html#ansible-community-changelogs)

---

<div class="post-metadata">

**Author:** ![Dragao](https://avatars.discourse-cdn.com/v4/letter/d/ecb155/32.png) [@Dragao](https://forum.ansible.com/u/Dragao)\
**Post date:** [February 7, 2024, 4:05pm UTC](https://forum.ansible.com/t/unsupported-parameter-module-security-vmware-vswitch/3729/9 "2024-02-07T16:05:26Z")

</div>

Yes will do.

Thanks for the assistance
