# Oracle/Python

**URL:** <https://forum.ansible.com/t/oracle-python/34703>\
**Category:** Ansible Project\
**Created:** [March 1, 2021, 6:18pm UTC](https://forum.ansible.com/t/oracle-python/34703 "2021-03-01T18:18:21Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Keith\_Mills](https://avatars.discourse-cdn.com/v4/letter/k/b77776/32.png) [@Keith\_Mills](https://forum.ansible.com/u/Keith_Mills)\
**Post date:** [March 1, 2021, 6:18pm UTC](https://forum.ansible.com/t/oracle-python/34703/1 "2021-03-01T18:18:21Z")

</div>

Hello All,

I’m working on a project with Oracle Exalogic engineered systems that run OL 5.x which has Python 2.4 (ansible wants 2.6 +). I deployed a custom-compiled python but it apparently missing lots of python modules so ansible playbooks still fails. Since it’s an engineered system, oracle controls the updates for it. Since it’s based on Oracle Linux 5.x, Python 2.4 is latest provided by Oracle.

Can anyone give direction on how to resolve this issue?

Regards,

Keith

---

<div class="post-metadata">

**Author:** ![Dick\_Visser](https://avatars.discourse-cdn.com/v4/letter/d/d9b06d/32.png) [@Dick\_Visser](https://forum.ansible.com/u/Dick_Visser)\
**Post date:** [March 1, 2021, 6:31pm UTC](https://forum.ansible.com/t/oracle-python/34703/2 "2021-03-01T18:31:25Z")

</div>

Upgrade to Oracle Linux 6.0 which has python 2.6

---

<div class="post-metadata">

**Author:** ![Keith\_Mills](https://avatars.discourse-cdn.com/v4/letter/k/b77776/32.png) [@Keith\_Mills](https://forum.ansible.com/u/Keith_Mills)\
**Post date:** [March 1, 2021, 6:49pm UTC](https://forum.ansible.com/t/oracle-python/34703/3 "2021-03-01T18:49:29Z")

</div>

Hi Dick,

Cannot upgrade to Oracle Linux 6.0, it’s an engineered system, self-contained bundled config sold that way by Oracle.

---

<div class="post-metadata">

**Author:** ![Dick\_Visser](https://avatars.discourse-cdn.com/v4/letter/d/d9b06d/32.png) [@Dick\_Visser](https://forum.ansible.com/u/Dick_Visser)\
**Post date:** [March 1, 2021, 7:33pm UTC](https://forum.ansible.com/t/oracle-python/34703/4 "2021-03-01T19:33:33Z")

</div>

In that case you should not use ansible at all to manage this system.  
There is a reason ansible requires python 2.6+. So even if you would somehow get this (arcane and probably insecure) python version to work on your host, there will then be problems with ansible.

If you really must, then revisit the way you added your own compiled python and make that work. Since you actually seem to have paid for this system, I would suggest contacting the vendor for help on shoehorning such an ansible supported (but unsupported from the vendors point) python version into your system.

Dick

---

<div class="post-metadata">

**Author:** ![Keith\_Mills](https://avatars.discourse-cdn.com/v4/letter/k/b77776/32.png) [@Keith\_Mills](https://forum.ansible.com/u/Keith_Mills)\
**Post date:** [March 2, 2021, 12:55pm UTC](https://forum.ansible.com/t/oracle-python/34703/5 "2021-03-02T12:55:18Z")

</div>

Thank you for the information, it is well received.
