# Collection community.vmware does not support Ansible version 2.14.17

**URL:** <https://forum.ansible.com/t/collection-community-vmware-does-not-support-ansible-version-2-14-17/43553>\
**Category:** Get Help\
**Tags:** vmware\
**Created:** [June 25, 2025, 4:41pm UTC](https://forum.ansible.com/t/collection-community-vmware-does-not-support-ansible-version-2-14-17/43553 "2025-06-25T16:41:11Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![jaquayla](https://avatars.discourse-cdn.com/v4/letter/j/919ad9/32.png) [@jaquayla](https://forum.ansible.com/u/jaquayla)\
**Post date:** [June 25, 2025, 4:41pm UTC](https://forum.ansible.com/t/collection-community-vmware-does-not-support-ansible-version-2-14-17/43553/1 "2025-06-25T16:41:11Z")

</div>

I am getting this error:

[WARNING]: Collection community.vmware does not support Ansible version 2.14.17

What version supports community.vmware? Or is there a workaround for this?

---

<div class="post-metadata">

**Author:** ![mariolenz](https://sea1.discourse-cdn.com/ansible/user_avatar/forum.ansible.com/mariolenz/32/108_2.png) [@mariolenz](https://forum.ansible.com/u/mariolenz)\
**Post date:** [June 25, 2025, 5:20pm UTC](https://forum.ansible.com/t/collection-community-vmware-does-not-support-ansible-version-2-14-17/43553/2 "2025-06-25T17:20:54Z")

</div>

Depends on what version of the collection you’re using 😏

---

<div class="post-metadata">

**Author:** ![felixfontein](https://sea1.discourse-cdn.com/ansible/user_avatar/forum.ansible.com/felixfontein/32/7530_2.png) [@felixfontein](https://forum.ansible.com/u/felixfontein)\
**Post date:** [June 25, 2025, 5:47pm UTC](https://forum.ansible.com/t/collection-community-vmware-does-not-support-ansible-version-2-14-17/43553/3 "2025-06-25T17:47:58Z")

</div>

Galaxy shows the required ansible-core version for every collection version: [Ansible Galaxy](https://galaxy.ansible.com/ui/repo/published/community/vmware/). For the latest version, it says `>=2.17.0`.

If you use the version selector to pick an older version (beware that it by default only shows the last 10 releases, which all belong to the same major release), you can see which ansible-core version it supports.

---

<div class="post-metadata">

**Author:** ![jaquayla](https://avatars.discourse-cdn.com/v4/letter/j/919ad9/32.png) [@jaquayla](https://forum.ansible.com/u/jaquayla)\
**Post date:** [June 25, 2025, 6:23pm UTC](https://forum.ansible.com/t/collection-community-vmware-does-not-support-ansible-version-2-14-17/43553/4 "2025-06-25T18:23:54Z")

</div>

Collection Version

* * *

community.vmware 5.7.1  
vmware.vmware 2.2.0

---

<div class="post-metadata">

**Author:** ![jaquayla](https://avatars.discourse-cdn.com/v4/letter/j/919ad9/32.png) [@jaquayla](https://forum.ansible.com/u/jaquayla)\
**Post date:** [June 25, 2025, 6:26pm UTC](https://forum.ansible.com/t/collection-community-vmware-does-not-support-ansible-version-2-14-17/43553/5 "2025-06-25T18:26:27Z")

</div>

Currently running on ansible 2.14. Trying to upgrade but I cant find the 2.17 repo to install

---

<div class="post-metadata">

**Author:** ![mariolenz](https://sea1.discourse-cdn.com/ansible/user_avatar/forum.ansible.com/mariolenz/32/108_2.png) [@mariolenz](https://forum.ansible.com/u/mariolenz)\
**Post date:** [June 26, 2025, 3:03pm UTC](https://forum.ansible.com/t/collection-community-vmware-does-not-support-ansible-version-2-14-17/43553/6 "2025-06-26T15:03:35Z")

</div>

Personally, I prefer to install directly from [PyPI](https://pypi.org/project/ansible-core/) with pip into a [venv](https://www.w3schools.com/python/python_virtualenv.asp).
